1
Fork 0
hare-playground/flake.nix

34 lines
787 B
Nix

{
description = "Hare for mac";
inputs = {
hare-pkgs = {
url = "git+https://git.fnordig.de/jer/hare-mac.git?ref=main";
};
};
outputs = { nixpkgs, hare-pkgs, ... }:
let
supportedSystems = [ "x86_64-darwin" "aarch64-darwin" "x86_64-linux" "aarch64-linux" ];
forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
in
{
devShells = forAllSystems (system:
let
pkgs = nixpkgs.legacyPackages.${system};
hare-pkgs' = hare-pkgs.packages.${system};
harec = hare-pkgs'.harec;
hare = hare-pkgs'.hare;
in
{
default = pkgs.mkShell {
buildInputs = [
harec
hare
pkgs.hurl
];
};
});
};
}